Forcer le mode de compatibilité d’Internet Explorer 8

IE 8 est disponible depuis courant mars pour les utilisateurs de Windows. Il est facile de trouver une liste des améliorations qu’apporte cette version sur le web, c’est pourquoi nous nous attarderons uniquement sur les problèmes que peux entraîner celle-ci 😉

Sans rentrer dans le détail (car pour le moment aucune compatibilité avec IE 8 n’est envisagée dans les projets auxquels je participe), voici ce qu’IE ne supporte toujours pas :

  • La transparence CSS (propriété opacity) ainsi que les valeurs RGBA
  • Le SVG et la balise HTML Canvas
  • XForms, WebForms, VoiceXML, MathML
  • CSS 3 dans sa majeure partie

La question de rendre compatible ou non ses projets web pour le moment se pose tout de même. En effet, une grande partie du marché des pro travaille dans un envirronement système ou intranet cadré par des administrateurs, et ceux-ci ne pourront sûrement pas bénéficier de la mise à jour d’Internet Explorer dans un premier temps. En revanche, les particuliers ont de gros risques de faire la mise à jour par le biais du système de mises à jour automatique de Windows (Windows Update).

C’est pourquoi, une partie de l’audience web utilisera surement ce navigateur dans les prochaines semaines.

Il n’est néanmoins pas nécessaire d’assurer une compatibilité avec IE 8 pour autant ! Et sur ce coup, Microsoft nous tend une perche… En effet, il est possible de forcer IE 8 a passer en mode de compatibilité IE 7 par le biais d’un meta tag :

Voilà qui devrait nous laisser un peu de temps pour appréhender cette nouvelle version de notre navigateur préféré (oupa).

Cette entrée a été publiée dans Actualités le par Nukium.